iManage is a great document management system, but sometimes you run into weird issues that will drive you nuts trying to fix them.

Recently, one such issue starting cropping up for some clients. In particular, if you use the Email Mangement (EMM) Toolbar / functionality for iManage / FileSite, you may run into an issue where the toolbar add-in stubbornly refuses to load.

You may have it set via Group Policy or the Windows registry to force it to load but it does not. You go through the standard Repair / Uninstall / Reinstall steps with the FileSite client but the issue persists.

Maybe you run Outlook as Administrator, and this allows the toolbar to load (or perhaps you can’t use this option if you’re in a locked down environment where users are not local administrators of their workstations). Neither scenario is ideal for the long-term.

One cause for this issue is that the security of the Office.dll file bured deep under the C:\Windows\Assembly folder gets messed up, and the user (or Everyone group) has no permissions to it.

First, note that you may just see assembly packages and not files / folders under C:\Windows\Assembly. If this is the case, you will need to make the following registry change:

Path: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Fusion
Item: DisableCacheViewer
Value: (DWORD) 1

Reboot your PC and verify you can now see the standard file / folder structure under C:\Windows\Assembly.

Search for the Office.dll file, and browse to it’s location. You’ll have to experiment a little but typically altering the security permissions for this file (or folder, if necessary) to grant the Everyone group READ access fixes the issue.

2 Replies to “iManage / FileSite EMM Toolbar issue”

Comments are closed.